Menús de configuración en el Panel de Administración

IkaroTech

Capítulo 3: Estructuras de Decisión

Son estructuras de control de flujo, que permiten seleccionar la próxima sentencia a ejecutar sobre la base de una decisión (Expresión lógica o variable lógica)

 

Los tipos de estructuras de decisión son:

  • Simples
  • Dobles
  • Anidadas

La sentencia “IF” es utilizada para tomar decisiones y su formato es:

 

Pseudocódigo

Si (condición) entonces

Sentencias…

Fin si

 

  • Sí (básico y compuesto)

Las estructuras de decisión doble permiten ejecutar dos conjuntos de sentencias alternativos en función del resultado de la evaluación de una condición lógica.

 

  • Si el resultado es “cierto” se ejecuta un grupo de sentencias.
  • Si el resultado es “falso” se ejecuta otro grupo de sentencias.

 

Formato en pseudo código

Si ( decisión ) entonces

sentencias….

Si no

sentencias….

fin si

 

Diagrama de flujo validar si un número es positivo o negativo en DFD

condicional1

La sentencia if – else es utilizada para tomar decisiones y su formato es:

if ( expresión lógica)

{

sentencias….

}

Else

{

sentencias….

}

La condición anidada permite validar 2 o más condiciones, de tal forma sea más exacta la validación.

Ejercicio:

Leer un número digitado por el usuario, determinar si dicho número cumple las siguientes condiciones.

a. Si el número es cero, validar su resultado como Neutro.

b. Validar si el número es positivo

c. Validar si número es negativo

 

cond anidada1

como podemos ver en el anterior ejercicio la primera validación filtra todos aquellos valores que sean iguales a cero, el segundo condicional determina si el número es mayor o menor que cero, para definir si es positivo o negativo.

Ejercicios:

Determinar si un número ingresado por el usuario es par o impar

 

1. Analizamos las variables a utilizar, al ser un número ingresado por el usuario, cuyo resultado sera un si o no, determinamos que sólo es necesaria una variable la cual denominaremos “a” con valor inicial  cero –> a=0.

2. solicitamos al usuario que ingrese el valor a validar.

3. Utilizamos el operador mod el cual nos determina si el residuo de ese número dividido por 2 es cero, en caso de no ser cero el resultado será impar, en caso de ser cero el resultado sera par.

dfdparimpar

Determinar entre dos valores ingresados por el usuario el mayor y el menor

1. Analizamos las variables a utilizar, el usuario debe ingresar 2 valores, porlo tanto necesitamos 2 variabels para comparar  “a” y “b” los cuales iniciaremos en cero

–> a=0, b=0

2. solicitamos al usuario que ingrese los valores a validar.

3. Utilizamos los operadores < y > para para validar los números, en caso de no ser mayor o menor los números serán iguales.

compara mayormenor

 

 Ejercicio 1: Determinar si un número ingresado por el usuario es par o impar

Solución:

Proceso parimpar

escribir “ingrese un número: “;
Leer a;
Si a%2=0 Entonces
Escribir “El número es par”;
Sino
Escribir “El número es impar”;
Fin Si

FinProceso

Ejercicio 2: Determinar entre dos valores ingresados por el usuario el mayor y el menor

Solución:

Proceso mayormenor
escribir “ingrese el primer número: “;
Leer a;
escribir “ingrese el segundo número: “;
Leer b;

Si a<b Entonces
Escribir “El número mayor es “,b;
Sino
Si a>b Entonces
Escribir “El número mayor es “,a;
Sino
Escribir “Los números son iguales”;
fin si
Fin Si

FinProceso

Estructuras de Decisión (Si Básico)

Estructuras de Decisión (Si Compuesto)

Estructuras de Decisión (Si Anidado)

Estructuras de Decisión (Selección Múltiple – Según Sea)

 

 

 

 

Ejercicio de Estructura de Decisión en DFD

Ejercicio de Estructuras de Decisión en PSEINT

Ver todo Añadir una nota
Tu
Agregue su comentario
IkaroTech © 2016. Todos los derechos reservados.